[SOLVED]kmess fails to build on kubuntu 11.10

Post a reply

:
In an effort to prevent automatic submissions, we require that you enter both of the words displayed into the text field underneath.

BBCode is OFF
Smilies are OFF
Topic review
   

Expand view Topic review: [SOLVED]kmess fails to build on kubuntu 11.10

Re: [SOLVED]kmess fails to build on kubuntu 11.10

Post by Ruben » January 29th, 2012, 3:00 pm

Well good to hear we could help you ;)

Re: [SOLVED]kmess fails to build on kubuntu 11.10

Post by Franklin » January 27th, 2012, 1:46 am

Okay, it's become a tradition that I would find out the solution right after I posted a help message...

The answer is: I didn't install g++ =_=

[SOLVED]kmess fails to build on kubuntu 11.10

Post by Franklin » January 27th, 2012, 1:29 am

Hi,

I checked out the latest git stable version but failed to build on kubuntu 11.10.
It kept telling me that gif_lib missing.
I'm sure that I installed libgif-dev and libgif4.


# dpkg -l | grep gif
ii libgif-dev 4.1.6-9 library for GIF images (development)
ii libgif4 4.1.6-9 library for GIF images (library)
# locate gif_lib.h
/usr/include/gif_lib.h
# locate libgif
/usr/lib/libgif.a
/usr/lib/libgif.la
/usr/lib/libgif.so
/usr/lib/libgif.so.4
/usr/lib/libgif.so.4.1
/usr/lib/libgif.so.4.1.6
/usr/share/doc/libgif-dev
/usr/share/doc/libgif4
/usr/share/doc/libgif-dev/AUTHORS
/usr/share/doc/libgif-dev/NEWS.gz
/usr/share/doc/libgif-dev/ONEWS.gz
/usr/share/doc/libgif-dev/TODO.gz
/usr/share/doc/libgif-dev/changelog.Debian.gz
/usr/share/doc/libgif-dev/changelog.gz
/usr/share/doc/libgif-dev/copyright
/usr/share/doc/libgif4/AUTHORS
/usr/share/doc/libgif4/NEWS.gz
/usr/share/doc/libgif4/ONEWS.gz
/usr/share/doc/libgif4/TODO.gz
/usr/share/doc/libgif4/changelog.Debian.gz
/usr/share/doc/libgif4/changelog.gz
/usr/share/doc/libgif4/copyright
/var/cache/apt/archives/libgif-dev_4.1.6-9_i386.deb
/var/lib/dpkg/info/libgif-dev.list
/var/lib/dpkg/info/libgif-dev.md5sums
/var/lib/dpkg/info/libgif4.list
/var/lib/dpkg/info/libgif4.md5sums
/var/lib/dpkg/info/libgif4.postinst
/var/lib/dpkg/info/libgif4.postrm
/var/lib/dpkg/info/libgif4.shlibs
/var/lib/dpkg/info/libgif4.symbols

And here is what I got when running cmake:

# cmake -DCMAKE_INSTALL_PREFIX=/usr/local/kmess ..
-- The C compiler identification is GNU
-- The CXX compiler identification is unknown
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.7.4 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/i386-linux-gnu/libX11.so;/usr/lib/i386-linux-gnu/libXext.so;/usr/lib/i386-linux-gnu/libXau.so;/usr/lib/i386-linux-gnu/libXdmcp.so
-- Looking for XOpenDisplay in /usr/lib/i386-linux-gnu/libX11.so;/usr/lib/i386-linux-gnu/libXext.so;/usr/lib/i386-linux-gnu/libXau.so;/usr/lib/i386-linux-gnu/libXdmcp.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Found X11: /usr/lib/i386-linux-gnu/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Found Phonon: /usr/include
-- Performing Test _OFFT_IS_64BIT
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (GET_FILENAME_COMPONENT):
get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Performing Test _OFFT_IS_64BIT - Failed
-- Found KDE 4.7 include dir: /usr/include
-- Found KDE 4.7 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found LibXml2: /usr/lib/libxml2.so
-- Found LibXslt: /usr/lib/libxslt.so
-- Found GCrypt: /lib/i386-linux-gnu/libgcrypt.so
-- Looking for GCrypt - found
-- Found X11: /usr/lib/i386-linux-gnu/libX11.so
-- Found LIBKONQ: /usr/include

-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
-----------------------------------------------------------------------------
* LibXML2 - Libraries used to develop XML-aware applications
* LibXSLT - A library to transform XML into other formats
* XScreenSaver - X11 extension used to check idle state
* LibKonq - Integration with Konqueror context menu

-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
-----------------------------------------------------------------------------
* LibISF-Qt <http://www.kmess.org/>
Library to manage Microsoft's Mobile Ink
Support to send handwriting messages in a format compatible with Windows Live Messenger.
In absence of an installed isf-qt version, the bundled version will be compiled.

-----------------------------------------------------------------------------

CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
-- Will build Isf-Qt in bundled mode.
-- Found Qt-Version 4.7.4 (using /usr/bin/qmake)
-- Found X11: /usr/lib/i386-linux-gnu/libX11.so
CMake Warning (dev) at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:86 (INCLUDE):
File /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake
includes /usr/share/kde4/apps/cmake/modules/CMakeParseArguments.cmake
(found via CMAKE_MODULE_PATH) which shadows
/usr/share/cmake-2.8/Modules/CMakeParseArguments.cmake. This may cause
errors later on .

Policy CMP0017 is not set: Prefer files from the CMake module directory
when including from there. Run "cmake --help-policy CMP0017" for policy
details. Use the cmake_policy command to set the policy and suppress this
warning.
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindThreads.cmake:156 (INCLUDE)
/usr/share/kde4/apps/cmake/modules/Qt4ConfigDependentSettings.cmake:32 (FIND_PACKAGE)
/usr/share/kde4/apps/cmake/modules/FindQt4.cmake:1230 (INCLUDE)
contrib/isf-qt/CMakeLists.txt:41 (FIND_PACKAGE)
This warning is for project developers. Use -Wno-dev to suppress it.

-- Looking for GifLib
-- Performing Test GIF_FOUND
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (GET_FILENAME_COMPONENT):
get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Performing Test GIF_FOUND - Failed
-- Looking for GifLib - not found!
CMake Error at contrib/isf-qt/CMakeLists.txt:57 (MESSAGE):
Support to read and write Fortified-GIF images is missing.

* You will need to install both the library and development packages of the GIF Library, giflib.
* Usually the package names for this library are:
on Ubuntu: 'libgif4' and 'libgif-dev'
on openSUSE: 'giflib' and 'giflib-devel'
* The project homepage is http://sourceforge.net/projects/giflib/



-- Configuring incomplete, errors occurred!

Could anyone please help me with this? Thanks.

Top

cron